こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

CentOSのセキュリティパッチについて

CentOS6.9およびCentOS7を使用していますがyumコマンドで
セキュリティパッチの適用はできなくなったのでしょうか?
以下のURLの”CentOS 7でyumからSecurityUpdateを行えるようにする”
https://orebibou.com/2016/09/centos-7でyumからsecurityupdateを行えるようにする/#comment-166410”
では、”CentOSのリポジトリではセキュリティアップデートの情報が提供されていないことが原因”と書いておりリポジトリの作成方法が紹介されています。
(記述通りやりましたが、うまく機能しませんでした…)
実際”yum --security check-update”では、パッチの一覧が表示されますが
”yum --security update”を実行すると
------------------------------ここから
読み込んだプラグイン:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.usonyx.net
* extras: centos.usonyx.net
* nux-dextop: li.nux.ro
* updates: centos.usonyx.net
No packages needed for security; 0 packages available
No packages marked for update
---------------------------------------ここまで
とupdateが無いと返されます。
本当にセキュリティパッチの提供をやめてしまったのでしょうか?
ご教示をお願いいたします。

投稿日時 - 2018-04-27 14:27:31

QNo.9492782

困ってます

質問者が選んだベストアンサー

yum --security check-update での最後の一行になんて書いてあるでしょうか?
私の場合はずらずら出ますが最後は「No packages needed for security; 0 packages available」
つまりアップデートが必要なものはない、という意味で終わっています

アップデートが必要なものがないのであればアップデートされません

補足お願いします

投稿日時 - 2018-04-27 14:44:41

補足

早速の回答ありがとうございます。
最後の1行は、agehage さんの指摘通り
”No packages needed for security; 0 packages available”
でした。
アップデートが必要なものがないという事なのでしょう。
納得がいかないのが、RedHatも使用しているのですが RedHat側では
毎日Red Hat Eratta Notificationが通知されてきています。
いくらCentOSのアップデート対応が遅いといってもこのような差が
あるのもなのでしょうか?

投稿日時 - 2018-04-27 15:39:00

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問