こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

python-oauth2のインストール失敗?

python-twitterを使用してbotを作ろうとしています。
こちら( http://pika-shi.hatenablog.com/entry/20110902/1314965054 )の記事を参考に、
simplejson 3.6.4
python-oauth2
HTTPLib2
python-twitter-1.1
の順にインストールしましたが、simplejson 3.6.4と、python-oauth2に関して下記のようなメッセージが出ました。

simplejson 3.6.4
( http://cheeseshop.python.org/pypi/simplejson )

---ここから---
***************************************************************************
WARNING: The C extension could not be compiled, speedups are not enabled.
Failure information, if any, is above.
I'm retrying the build without the C extension now.
***************************************************************************

***************************************************************************
WARNING: The C extension could not be compiled, speedups are not enabled.
Plain-Python installation succeeded.
***************************************************************************
---ここまで---

python-oauth2
( http://github.com/simplegeo/python-oauth2 )

---ここから---
Traceback (most recent call last):
File "setup.py", line 2, in <module>
from setuptools import setup, find_packages
ImportError: No module named setuptools
---ここまで---

HTTPLib2、python-twitter-1.1に関してはエラーメッセージは出ず、正常にインストールされました。
simplejson 3.6.4の「The C extension」は、C系の言語でしょうか? 確かに特にC系の言語は入れていません。
SimpleGeo's OAuth2に関しては、setuptoolsというモジュールがどこにあるのかが分かりません。
参考にした記事は2011年ですから、他にも必要なモジュールなどがあるのでしょうか?

よろしくお願いいたします。

投稿日時 - 2014-10-14 04:41:27

QNo.8789946

困ってます

質問者が選んだベストアンサー

http://sekai.hateblo.jp/entry/2013/07/21/182827

Pythonを使ってTwitterBot 

http://hyokonia.tumblr.com/post/3733873984/python-distribute-easy-install-windows
setuptoolsのことがかかれてます

http://azwoo.hatenablog.com/entry/2013/12/18/165101
ここによるとsimplejsonのほうはたぶん警告なので大丈夫そう???

投稿日時 - 2014-10-15 20:51:53

お礼

ありがとうございます!
色々入れないといけないライブラリがあるんですね。
解決しました!

投稿日時 - 2014-10-16 04:00:05

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問